Registration bug and contact form bug

Sorry to post here but the contact form doesn't work! Trying to send this message with it gave me "Validation error, please try again. If this error persists, please contact the site administrator." Which is of course funny because it is the only way given to contact the site administrator.

So anyways here's the other bug I wanted to contact the site administrator about:

When I visited the URL http://skepticsinthepub.net.nz/user/register there was an error box at the top of the page:
user warning: Table 'skepticsinthepub.signup' doesn't exist query: SELECT DISTINCT n.nid FROM d6_node n INNER JOIN signup s on n.nid=s.nid INNER JOIN d6_node_access na ON na.nid = n.nid WHERE (na.grant_view >= 1 AND ((na.gid = 0 AND na.realm = 'all') OR (na.gid = 0 AND na.realm = 'content_access_author') OR (na.gid = 1 AND na.realm = 'content_access_rid'))) AND ( s.user_reg_form = 1 AND s.status = 1 AND n.status = 1) in /home/unifex/drupal6.evolved.net.nz/sites/all/modules/signup/signup.module on line 643.

Then after I filled in the registration form, the next page had this error at the top:
user warning: Table 'skepticsinthepub.signup' doesn't exist query: SELECT DISTINCT n.nid FROM d6_node n INNER JOIN signup s on n.nid=s.nid INNER JOIN d6_node_access na ON na.nid = n.nid WHERE (na.grant_view >= 1 AND ((na.gid = 0 AND na.realm = 'all') OR (na.gid = 0 AND na.realm = 'content_access_author') OR (na.gid = 1 AND na.realm = 'content_access_rid'))) AND ( s.user_reg_form = 1 AND s.status = 1 AND n.status = 1) in /home/unifex/drupal6.evolved.net.nz/sites/all/modules/signup/signup.module on line 643.

However registration seemed to work fine.

Trackback URL for this post:

http://skepticsinthepub.net.nz/trackback/308

These should be fixed now.

These should be fixed now. Thanks for the heads up and sorry for taking so long to deal to it. Life was a little insane for a while back there.